Publishing Content library Template to Subscriber Fails with "A general system error occurred: HostSystem does not exist"
search cancel

Publishing Content library Template to Subscriber Fails with "A general system error occurred: HostSystem does not exist"

book

Article ID: 445506

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Content library templates fail to publish and sync library items from publisher due to host resource unavailable at the destination site.

A general system error occurred: Failed to publish item ''CL_item'' (ID: 9XXXXXXX-eXXX-4XXX-bXXX-dXXXXXXXX7) to subscribed library ''ContentLibrary'' (ID: 4XXXXXX-aXXX-4XXX-9XXX-4XXXXXXXX3) on vCenter Server vcenter.fqdn.com. Reason: The object with ID host-XX and type HostSystem does not exist.

Compute Resource empty for publishing

Environment

vSphere 8.x

Cause

Destination site does not have HostSystem the publisher is looking for 'host-xx'

Resolution

To verify run the below commands from VCDB;

- Check the cl_subscription on the source vCenter, note down the host_id 'host-xx'

#  /opt/vmware/vpostgres/current/bin/psql -U postgres -d VCDB
psql.bin (14.19 (VMware Postgres 14.19.0-24974826 release))
Type "help" for help.

VCDB=# select * from cl_subscription;
id                  |          publishedlibraryid          |         subscribedlibraryid          | subscribedlibraryname |       subscriber_vcenter_hostname        | subscriber_vcenter_https_port |        subscriber_server_guid        |  folderid   | clusterid | resourcepoolid  |   hostid    |     networkid
--------------------------------------+--------------------------------------+--------------------------------------+-----------------------+------------------------------------------+-------------------------------+--------------------------------------+-------------+-----------+-----------------+-------------+--------------------
bxxxxxxx-bxxx-4xxx-8xxx-7xxxxxxxxx1 | fxxxxxx-9xxx-4xxx-axxx-3xxxxxxxx8 | 5xxxxxxx-exxx-4xxx-bxxx-fxxxxxxxx0 | Subscriber_ContentLibrary   | vcenter.fqdn.com |                               | xxxxxxxx8-dxxx-4xxx-9xxx-5xxxxxxxxxa | group-vxxx  |           | resgroup-xx     | host-xx     | dvportgroup-xxxx

- Run the below VCDB command on destination VC to verify if the host-xx from the previous step is available


VCDB=# select ctid,id,dns_name from VPX_HOST;
  ctid  |   id    |                 dns_name
--------+---------+------------------------------------------
(0,x)  |     xxx | esxi1.fqdn.com
(0,1)  |     xxx | esxi2.fqdn.com
(0,2)  |     xxx | esxi3.fqdn.com
(0,3)  |     xxx | esxi4.fqdn.com

(4 rows)

- After confirming the host-xx is missing at the destination VC, follow the below steps

Fix;

1. Login to the source CL VC with SSO admin user

2. Navigate to Content Libraries and select the Source CL

3. Click on Subscriptions tab

4. Select the Affected CL with Empty 'Compute Resource' and click 'Edit Subscription'

5. Now configure with correct Host resource and retry the Publish task.