VCF deployment fails on "Deploy and configure NSX" when the "Configure NSX Backup Schedule" task fails: "Failed to configure NSX Backup Schedule for NSX Managers"
search cancel

VCF deployment fails on "Deploy and configure NSX" when the "Configure NSX Backup Schedule" task fails: "Failed to configure NSX Backup Schedule for NSX Managers"

book

Article ID: 445442

calendar_today

Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

  • In the VCF Installer UI, the "Deploy and configure NSX" step shows a failure
  • In the Task details pane, the "Configure NSX Backup Schedule" has a status of Failed
  • The details of this failed task are similar to the following:

    Failed to configure NSX Backup Schedule for NSX Managers - [########] Reference Token: ######

  • On the SDDC Manager appliance, the backup user is NOT locked, so this is not the same issue in KB 399414

Environment

VCF 9.0

VCF 9.1

Cause

The issue is caused by one of the DNS servers is not working.

The issue is also seen in the validation that reverse DNS lookup has failed.

Login to the NSX Manager, and 

    cat  /etc/resolv.conf

It returns 2 DNS servers.

 

Run nslookup command with these 2 DNS servers, and found one of the DNS Servers cannot return resolved result.

Resolution

Remove the problematic DNS server from NSX Manager:

1) Check the current DNS Server settings:

get name-servers

2) Delete the problematic DNS Server

del    name-server    <DNSServer-IP>

 

3) Retry the deployment tasks in VCF 9.x