Install Service Using Fleet lifecycle. See Tasks panel to learn more.The Fleet lifecycle 'VSP component installation' task with ID [TASK_ID] failed.
Internal errors: A pre-validation prevented the bootstrap: From the IPv4 pool, found the following in-use IP address(es): 10.#.#.240., Failed to bootstrap VCF services runtime of type 'CONSUMPTION'.Internal errors: A pre-validation prevented the bootstrap: From the IPv4 pool, found the following in-use IP address(es): 10.#.#.240., Failed to bootstrap VCF services runtime of type 'CONSUMPTION'., A pre-validation prevented the bootstrap: From the IPv4 pool, found the following in-use IP address(es): 10.#.#.240., Failed to bootstrap VCF services runtime of type 'CONSUMPTION'., A pre-validation prevented the bootstrap: From the IPv4 pool, found the following in-use IP address(es): 10.#.#.240., Failed to bootstrap VCF services runtime of type 'CONSUMPTION'., A pre-validation prevented the bootstrap: From the IPv4 pool, found the following in-use IP address(es): 10.#.#.240., Failed to bootstrap VCF services runtime of type 'CONSUMPTION'., A pre-validation prevented the bootstrap: From the IPv4 pool, found the following in-use IP address(es): 10.#.#.240., Failed to bootstrap VCF services runtime of type 'CONSUMPTION'., A pre-validation prevented the bootstrap: From the IPv4 pool, found the following in-use IPaddress(es): 10.#.#.240., Failed to bootstrap VCF services runtime of type 'CONSUMPTION'., A pre-validation prevented the bootstrap: From the IPv4 pool, found the following in-use IP address(es): 10.#.#.240., Failed to bootstrap VCF services runtime of type 'CONSUMPTION'., A pre-validation prevented the bootstrap: From the IPv4 pool, found the following in-use IP address(es): 10.#.#.240., Failed to bootstrap VCF services runtime of type 'CONSUMPTION'., A pre-validation prevented the bootstrap: From the IPv4 pool, found the following in-use IP address(es): 10.#.#.240., Failed to bootstrap VCF services runtime of type 'CONSUMPTION'.
at com.vmware.vcf.vsp.services.fleetlcm.FleetLcmTaskExecutor.executeWithRetry(FleetLcmTaskExecutor.java:102)
at com.vmware.vcf.vsp.services.fleetlcm.actions.InstallVspComponentFleetLcmAction.execute(InstallVspComponentFleetLcmAction.java:58)
at com.vmware.vcf.vsp.services.fleetlcm.actions.InstallVspComponentFleetLcmAction.execute(InstallVspComponentFleetLcmAction.java:31)
at com.vmware.evo.sddc.orchestrator.platform.action.FsmActionState.invoke(FsmActionState.java:66)
at com.vmware.evo.sddc.orchestrator.platform.action.FsmActionPlugin.invoke(FsmActionPlugin.java:161)
at com.vmware.evo.sddc.orchestrator.platform.action.FsmActionPlugin.invoke(FsmActionPlugin.java:147)
at com.vmware.evo.sddc.orchestrator.core.ProcessingTaskSubscriber.invokeMethod(ProcessingTaskSubscriber.java:401)
at com.vmware.evo.sddc.orchestrator.core.ProcessingTaskSubscriber.processTask(ProcessingTaskSubscriber.java:515)
at com.vmware.evo.sddc.orchestrator.core.ProcessingTaskSubscriber.accept(ProcessingTaskSubscriber.java:128)
at java.base/jdk.internal.reflect.DirectMethodHandleAccessor.invoke(DirectMethodHandleAccessor.java:103)
at java.base/java.lang.reflect.Method.invoke(Method.java:580)
at com.google.common.eventbus.Subscriber.invokeSubscriberMethod(Subscriber.java:85)
at com.google.common.eventbus.Subscriber.lambda$dispatchEvent$0(Subscriber.java:71)
at com.vmware.vcf.common.tracing.TraceRunnable.run(TraceRunnable.java:63)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1144)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:642)
at java.base/java.lang.Thread.run(Thread.java:1583)
Collected the following errors for task with name InstallVspComponentFleetLcmAction and ID 0a#####d-9##d2-1##6-8##e-d####165: [ExecutionError [errorCode=null, errorResponse=LocalizableErrorResponse(messageBundle=com.vmware.evo.sddc.common.services.sddcman
agermessages)], ExecutionError [errorCode=null, errorResponse=LocalizableErrorResponse(messageBundle=com.vmware.evo.sddc.common.services.sddcmanagermessages)], ExecutionError [errorCode=null, errorResponse=LocalizableErrorResponse(messageBundle=com.vmware.evo.sddc.common.services.sddcmanagermessages)]]
DEBUG [c.v.e.s.o.c.ProcessingTaskSubscriber,dm-exec-1079] Invoking task InstallVspComponentFleetLcmAction.UNDO, Plugin: VspServicesPlugin, ParamBuilder null, Input map: {componentSpec=DeployOrJoinVcfManagementComponents____24__DeployVcfAutomationFleetLcm____15__componentSpec}, Id:
VMware Cloud Foundation 9.x
This issue occurs because the IP addresses allocated for the VCF Automation nodes or VSP cluster services reside within the CIDR range dedicated to the management network or internal cluster services. VCF pre-validation prevents bootstrapping if it detects that the IP addresses it intends to use for service runtimes are "in-use" or overlap with the defined network CIDR boundaries.
To resolve this, ensure that all static IP addresses assigned to appliances and service pools are outside of the CIDR ranges dedicated to internal service runtimes or other overlapping network segments. Steps to fix: