vc-support command displays warnings similar to:YYYY-MM-DD HH:MM:SS,### WARNING authzData.py:116 Failed to find principal: <AD user account>Traceback (most recent call last): File "/usr/lib/vmware/site-packages/supportbundle/authzData.py", line 112, in _fetch_users principal = _get_principal(name, isGroup) File "/usr/lib/vmware/site-packages/supportbundle/authzData.py", line 140, in _get_principal sso_sic.principalDiscoveryService.FindUsersInGroup( File "/usr/lib/vmware/site-packages/pyVmomi/VmomiSupport.py", line 618, in <lambda> self.f(*(self.args + (obj,) + args), **kwargs) File "/usr/lib/vmware/site-packages/pyVmomi/VmomiSupport.py", line 391, in _InvokeMethod return self._stub.InvokeMethod(self, info, args) File "/usr/lib/vmware/site-packages/pyVmomi/SoapAdapter.py", line 1796, in InvokeMethod raise objpyVmomi.VmomiSupport.sso.fault.InternalFault: (sso.fault.InternalFault) { dynamicType = <unset>, dynamicProperty = (vmodl.DynamicProperty) [], msg = "Idm client exception: Can't contact LDAP server", faultCause = <unset>, faultMessage = (vmodl.LocalizableMessage) []Note: "WARNING authzData.py:116 Failed to find principal: VSPHERE.LOCAL\WorkloadStorage" can be ignored.
vCenter Server 8.0
When generating a support bundle, vCenter Server attempts to collect authorization data, which includes mapping vCenter permissions to users and groups. To do this accurately, it must resolve the "Principals" (users/groups) defined in the Identity Sources.
If an Active Directory identity source has been configured, vc-support calls the Identity Management (IDM) service to find these users. The "Can't contact LDAP server" error indicates that the vCenter's IDM service cannot reach the Domain Controllers over the LDAP/LDAPS ports (389/636).
The support bundle collection process is sequential. If the error occurs for each AD users, the entire bundle generation remains stuck at that stage—which frequently happens around the 20% mark.
Fix the connectivity or temporarily remove the unreachable Identity Source if it's no longer used.
To check Identity Source Health and test connectivity:
curl -v telnet://<DC_IP_OR_FQDN>:636
openssl s_client -connect <DC_IP_OR_FQDN>:636 -showcerts/opt/vmware/bin/sso-config.sh -get_identity_sourcesIf the certificate is expired, renew it.