Service Catalog does not allow attachments with a space in the filename.
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Service Catalog does not allow attachments with a space in the filename.

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Article ID: 44481

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Updated On:

Products

CA Service Catalog CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

when a user tries to add a file with a space in the name as an attachment, the counter is incremented, but the file is not attached.

 

 

Environment

CA Service Catalog 17.X.

Cause

The %USM_HOME%\view\conf\ESAPI.properties file contains configuration information which govern the behavior of Service Catalog attachments. This file has been revised in cumulative fix pack 1 and this revision cause this behavior.

Resolution

1) Edit the %USM_HOME%\view\conf\ESAPI.properties file.
2) Go to the end of the file, there should be these lines:

Validator.FileName=^[a-zA-Z0-9\\p{L}!@#$%^&{}\\[\\]()_+\\-=,.~'`]{1,255}$
Validator.DirectoryName=^[a-zA-Z0-9:/\\\\!@#$%^&{}\\[\\]()_+\\-=,.~'` ]{1,255}$

3) Edit the second line from the end and add a space character immediately before the ] character so

Validator.FileName=^[a-zA-Z0-9\\p{L}!@#$%^&{}\\[\\]()_+\\-=,.~'`]{1,255}$

becomes

Validator.FileName=^[a-zA-Z0-9\\p{L}!@#$%^&{}\\[\\]()_+\\-=,.~'` ]{1,255}$

4) Save this change.
5) Restart the Service Catalog service.