var/log/vmware/vcf/domainmanager/domainmanager.log on VCF installer. "id": "##########", "type": "com.vmware.vcfms.task.InstallVcfmsComponent", "phase": "Failed", "status": "Failed", "createdBy": "<service_account>", "messages": [ { "id": "com.vmware.vcfms.bootstrap.GenericError", "level": "ERROR", "default": "Bootstrap failed during stage 'INIT0001 - Validating configuration': INGRESS_PLATFORM_FQDN '<<FQDN>>' could not be resolved via nameserver(s): 127.0.0.1 Please retry the operation or contact support if the issue persists. [VCFMS-BOOTSTRAP-999]", "stage": "INIT0001 - Validating configuration", "args": [ "INIT0001 - Validating configuration", "INGRESS_PLATFORM_FQDN <FQDN>' could not be resolved via nameserver(s): 127.0.0.1" ], "messageCode": "VCFMS-BOOTSTRAP-999"VMware vSphere Foundation 9.1
This issue occurs due to a misconfiguration in the OS-level DNS settings on the vCenter Server. In the /etc/resolv.conf file, the actual infrastructure DNS server entry is hashed out (commented out), leaving only the local loopback address (127.0.0.1) active. Because the active nameserver is strictly local, the vCenter is unable to resolve the external infrastructure FQDNs required to pass the bootstrap configuration validation check.
# vi /etc/resolv.confnameserver 127.0.0.1
#nameserver <DNS_IP> #nameserver 127.0.0.1nameserver <REDACTED_IP>
nslookup <REDACTED_HOSTNAME>/etc/resolv.conf file in a VC looks like this, by default cat /etc/resolv.conf
# This is /run/systemd/resolve/resolv.conf managed by man:systemd-resolved(8).
# Do not edit.
#
# This file might be symlinked as /etc/resolv.conf. If you're looking at
# /etc/resolv.conf and seeing this text, you have followed the symlink.
#
# This is a dynamic resolv.conf file for connecting local clients directly to
# all known uplink DNS servers. This file lists all configured search domains.
#
# Third party programs should typically not access this file directly, but only
# through the symlink at /etc/resolv.conf. To manage man:resolv.conf(5) in a
# different way, replace this symlink by a static file or a different symlink.
#
# See man:systemd-resolved.service(8) for details about the supported modes of
# operation for /etc/resolv.conf.
nameserver 127.0.0.1
nameserver XXX.XXX.XXX.XXX => your actual DNS1
nameserver XXX.XXX.XXX.XXX => your actual DNS2
search <domain name> => search in domain TBD