Resetting Passwords for VMware Cloud Foundation Services Runtime
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Resetting Passwords for VMware Cloud Foundation Services Runtime

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Article ID: 444448

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Updated On:

Products

VCF Automation VCF Operations

Issue/Introduction

In VCF 9.1, we leverage two key accounts in every VCF Services Runtime platform

  1. vmware-system-user
    • Local OS account used for gaining access to a Service Runtime node.
  2. [email protected]
    • API account used for interacting with various components which are running in a Services Runtime platform.

Environment

  • VCF Management Services 9.1.0
  • VCF Services Runtime 9.1.0

Cause

When deploying VCF, the password for vmware-system-user and [email protected] will be:

  1. Set during the deployment.
  2. Available only from the Deployment UI.
  3. The value set for the VCF Management Services 'password' during the deployment wizard will be used as the initial value for both.

 

If you lose access to either of these passwords you can use the KBs referenced below to reset the passwords for each account.

 

Note:

Resolution

Over time, for a number of reasons you may lose access to one or more of the accounts and you may need to reset those passwords.

Additional Information

This is the VCF default password policy that VMSP applies on a fresh cluster:

complexityConstraint:
  minLength: 15
  minLowercase: 1
  minNumeric: 1
  minSpecial: 1
  minUppercase: 1
  passwordHistory: 5
expirationConstraint:
  passwordExpirationDays: 365
lockoutConstraint:
  lockoutEvaluationPeriod: 900
  lockoutMaxAuthFailures: 3
  lockoutPeriod: 900
policyId: default
policyInfo:
  description: VSP Default Password Policy
  policyName: VSP Default Password Policy

 

This applies to both [email protected] and vmware-system-user.