Following an upgrade to vSphere Replication 9.0.2.3 in a legacy setup, vSphere Replication Site pairs display as broken or disconnected. Error messages indicating site pairing issues are visible on the Disaster Recovery (DR) client page.
The /opt/vmware/hms/logs/hms.log on the vSphere Replication appliance contains connection timeout errors attempting to reach ESXi host IP addresses on port 443. ERROR com. vmware. hms. hbrsrvuw. HbrsrvuwRegistrarService [hms-main-thread-18] ( .. hms. hbrsrvuw. HbrsrvuwRegistrarService$HostTask) [operationID=bdd4074d-eb63-4fdc-a5da-4######## d-HMSINT-325] | Repair hbrsrvuw from host-4##6 ... FAILED (HTID-04f4d84e-24a3-48b9-a341-5#########1) ; will retry com. vmware. vim.binding.hms . remote. fault. ConnectionFault: Cannot start connection to VR Server https: //10.###.###.8: 443/hbr: https: //10.###.###.8: 443/hbr invocation failed with "org. apache. http. conn. ConnectTimeoutException: Connect to 10.###.###.8:443 [/10.###.###.8] failed: Connect timed out"
Attempting to ping the ESXi host management IPs from the vSphere Replication appliance SSH console results in 100% packet loss.root [ /opt/vmware/hms/logs ]# ping 10.###.###.8PING 10.###.###.8 (10.###.###.8) 56(84) bytes of data.--- 10.###.###.8 ping statistics ---19 packets transmitted, 0 received, 100% packet loss, time 18411ms
$ curl -v telnet://127.0.0.1:8043* Trying 127.0.0.1:8043...* connect to 127.0.0.1 port 8043 from 127.0.0.1 port 55884 failed: Connection refused* Failed to connect to 127.0.0.1 port 8043 after 0 ms: Could not connect to server* closing connection #0curl: (7) Failed to connect to 127.0.0.1 port 8043 after 0 ms: Could not connect to serverThis issue is caused by a network communication failure between the vSphere Replication appliance and the local ESXi host over TCP port 443.
As a result:
To resolve this issue, engage your network or security team to open TCP port 443 between the vSphere Replication appliance and the local ESXi host.
Workaround
If you are using a legacy version of vSphere Replication and cannot immediately modify network firewall rules, contact Broadcom Support to request a temporary workaround.