Unable to modify an account template in the Identity Manager web UI, fails with a no such attribute error
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Unable to modify an account template in the Identity Manager web UI, fails with a no such attribute error

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Article ID: 44417

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Risk Analytics CA Secure Cloud SaaS - Arcot A-OK (WebFort) CLOUDMINDER ADVANCED AUTHENTICATION CA Secure Cloud SaaS - Advanced Authentication CA Secure Cloud SaaS - Identity Management CA Secure Cloud SaaS - Single Sign On

Issue/Introduction

Updating an account template in the IDM user console is not possible. Attempting to modify attributes results in a ‘no such attribute’ error, which appears in the server log. However, the template can be updated successfully through the provisioning manager.

Error code: Error: [LDAP: error code 16 - No Such Attribute]

Environment

Release: All
Component: Identity Manager

Resolution

Cause: 

When you run an etautil command it works directly with the provisioning server but does not notify Identity Manager's web UI. This is why the data is missing from your runtime database and why you cannot modify the templates correctly in the web UI, and only in provisioning manager. 

 

Workaround: 

Since the templates have already been created you will have to modify them in provisioning manager, but for the future please do not use etautil commands for anything you'd like to interact with using the IM web UI.