kubectl vsphere login command, the login fails with the following error:kubectl vsphere login --server <Control_plane_IP> --vsphere-username <User> --insecure-skip-tls-verify --tanzu-kubernetes-cluster-name <Cluster_Name> --tanzu-kubernetes-cluster-namespace <Namespace> -v10...INFO[0000] Using <User> as username.DEBU[0000] Env variable KUBECTL_VSPHERE_PASSWORD is presentDEBU[0000] Error while getting list of workloads: invalid or missing credentialsFATA[0000] Failed to get available workloads, response from the server was invalid./var/log/pods/kube-system_wcp-authproxy logs on the Supervisor node:DEBUG:auth.authentication_sso:Certificate failed verificationWARNING:auth.authentication_sso:Could not find a signing certificate to validate certificates present in the token: <cert>ERROR:auth.filters: SAML validation failed.<date><time> stderr F ERROR:auth.filters:[140182351438528] SAML <date><time> stderr F ERROR:auth.filters:[140182351438528] SAML validation failed.<date><time> stderr F Traceback (most recent call last):<date><time> stderr F File "/authproxy/auth/filters.py", line 201, in validate<date><time> stderr F saml_token.validate()<date><time> stderr F File "/authproxy/auth/authentication_sso.py", line 564, in validate<date><time> stderr F signing_chain = self.validate_certificate()<date><time> stderr F File "/authproxy/auth/authentication_sso.py", line 756, in validate_certificate<date><time> stderr F raise AuthenticationError(<date><time> stderr F auth.authentication_sso.AuthenticationError: No valid certificates.<date><time> stderr F ERROR:auth.filters:[140182351438528] Failed to obtain SAML token.<date><time> stderr F Traceback (most recent call last):<date><time> stderr F File "/authproxy/auth/filters.py", line 201, in validate<date><time> stderr F saml_token.validate()<date><time> stderr F File "/authproxy/auth/authentication_sso.py", line 564, in validate<date><time> stderr F signing_chain = self.validate_certificate()<date><time> stderr F File "/authproxy/auth/authentication_sso.py", line 756, in validate_certificate<date><time> stderr F raise AuthenticationError(<date><time> stderr F auth.authentication_sso.AuthenticationError: No valid certificates.vSphere Kubernetes Service
This issue occurs when the vCenter Security Token Service (STS) certificate is recently renewed, but the Supervisor clusters are not synchronized with the updated certificates.
Restart the Workload Control Plane (WCP) service on the vCenter Server to force a synchronization of the new certificates with the Supervisor clusters:
service-control --restart wcpkubectl vsphere login command to confirm access to the guest cluster.