Passive and Witness VMs remain in inventory after VCHA destruction
search cancel

Passive and Witness VMs remain in inventory after VCHA destruction

book

Article ID: 443817

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • The vSphere Client displays the following alert:
    "vCenter HA has invalid configuration. Remove vCenter HA to destroy current cluster configuration and setup vCenter HA again"

  • After destroying  the VCHA configuration, the logical destruction completes on the Active node, but the Passive and Witness VMs remain visible and running in the vCenter inventory.

Environment

vCenter Server

Cause

 The automated VCHA destruction workflow failed to clean up the secondary node VMs due to the previously degraded/invalid state of the vCenter HA cluster.

Resolution

  1. Manually power off the orphaned Passive and Witness node VMs.
  2. Delete the VMs from disk from the vCenter Server UI.