VCF Automation 9.1 installation fails with "Unable to determine deployment network."
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VCF Automation 9.1 installation fails with "Unable to determine deployment network."

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Article ID: 443713

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

  • When deploying VCF Automation 9.1, the installation fails during the "Install components using SDDC lifecycle service" step. The following error is displayed in the user interface:

    A pre-validation prevented the bootstrap: Unable to determine deployment network.
    Failed to bootstrap VCF services runtime of type 'CONSUMPTION'

  • The following subtask failure can be found in the log of sddc-build-service:

    arguments: ["Unable to determine deployment network."]
    context: null
    notifications: null
    message: VCF Management Services validations failed with the following errors: "Unable to determine deployment network."

  • In /var/log/vmware/vcf/domainmanager/domainmanager.log, the underlying authentication failure is recorded:

    Fetching System Info data from inventory
    Fetching Management vCenter data from inventory
    Unable to connect to [email protected]@<vCenter_Server_FQDN> com.vmware.vim.binding.vim.fault.InvalidLogin: Cannot complete login due to an incorrect user name or password.

  • This typically occurs if the [email protected] account password is recently reset directly within the vCenter Server and the account is showing as "disconnected" in SDDC Manager.

Environment

VMware Cloud Foundation 9.1.0

Cause

This issue occurs because the [email protected] password was changed directly on the vCenter Server, leaving the SDDC Manager out of sync. As SDDC Manager is unaware of the updated credentials, its connection to vCenter is broken. As a result, SDDC Manager cannot fetch the required inventory resources from the vCenter Server to deploy the VMware Service Platform for VCF Automation.

Resolution

To resolve this issue, remediate and update the [email protected] account credentials within SDDC Manager:

  1. Log in to the SDDC Manager UI.
  2. Navigate to Security > Password Management.
  3. Locate the [email protected] account for the vCenter Server.
  4. Select "Remediate" and input the current, correct password.
  5. Verify the status returns to valid, then retry the VCF Automation installation.