"Error "Critical Alarm: CNF is not upgraded to OCI-based Helm charts; all consecutive CNF LCM operations may fail."" while renewing harbor certificate.
search cancel

"Error "Critical Alarm: CNF is not upgraded to OCI-based Helm charts; all consecutive CNF LCM operations may fail."" while renewing harbor certificate.

book

Article ID: 443629

calendar_today

Updated On:

Products

VMware Tanzu Kubernetes Grid Management

Issue/Introduction

  • The certificate renewal for harbor standalone appliance was attempted by following the steps outlined in KB "Renewing SSL/TLS certificates for standalone harbor integrated with TCA"
  • Multiple critical alarms are reported in the VMware Telco Cloud Automation (TCA) UI post renewing the certificate 
  • The alarm displays the following error message: 

    "Critical Alarm: CNF is not upgraded to OCI-based Helm charts; all consecutive CNF LCM operations may fail."

Environment

  • VMware Telco Cloud Automation : 3.x.x
  • Harbor version  : 2.7.4

Cause

  • This is expected behavior caused by an incorrect command execution during the Harbor certificate renewal process.
  • When renewing the certificate, if the ./prepare script is run without the appropriate flags, it does not enable the chartmuseum service by default.
  • TCA continuously monitors the deployment and correctly detects that there are Cloud Native Network Functions (CNFs) still relying on chartmuseum-based charts. Because the underlying Harbor deployment is missing the required chartmuseum service, TCA raises the critical alarm to warn that Life Cycle Management (LCM) operations may fail.

Resolution


To resolve this issue and clear the alarms, you must ensure the chartmuseum service is running on your Harbor appliance.


1. Enable Chartmuseum: On the standalone Harbor appliance, re-run the prepare script with the chartmuseum flag included:

   ./prepare --with-chartmuseum

2. Verify the Service by ensuring that, the chartmuseum service has successfully started and is up and running on Harbor.

3. Clear the Alarms,once the service is running, the condition triggering the error is resolved.

4. Navigate to the TCA Alarms dashboard and acknowledge the raised alarms, and delete them.