Block mode TIRM062E "USER PROFILE ERROR: DUPLICATE KEY DETECTED"
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Block mode TIRM062E "USER PROFILE ERROR: DUPLICATE KEY DETECTED"

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Article ID: 44357

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Updated On:

Products

Gen

Issue/Introduction

Using a Gen 8.6 generated block mode application.
After initially executing transactions successfully the screen shows this error: 

TIRM062E: USER PROFILE ERROR: DUPLICATE KEY DETECTED

Environment

Gen Block Mode applications

Cause

See the Gen 8.6 doc page for TIRM062E.

The record retrieved from the runtime profile stack was placed on the stack by this user but not during the current procedure step. This may be due to more than one user being logged on with the same user ID (if so, ensure that only one user logs on with a user ID) or (under IMS) clearing the screen and entering a transaction before a response to a prior transaction is received (in that case, press PA2 until you get a response to the first transaction). To prevent from happening again, modify the user ID exit to use terminal ID for the profile key instead of user ID.

Resolution

So the error indicates there is a user ID uniqueness conflict in the runtime profile stack for the Gen block mode application.
For runtime profile stack information see doc. reference Host Encyclopedia Construction > Specify Target Environment for HE > Target Application Environment and section "Restartable Application" i.e.
"Gen generated applications use a temporary runtime stack, the Profile Database, to maintain execution context. Gen maintains one stack for each business system for each user. ..."

For the user experiencing the problem with a particular transaction (trancode) enter this on a clear screen: trancode RESET.
The RESET command should clear the profile stack of any "old" data that might be causing the error.

Per the doc. page, in general for users running the same Gen application ensure that only one user is logged in with the same User ID.