After running the vCenter 9 RDU upgrade precheck and not moving forward with the upgrade for any reason when rebooting the vCenter 8 appliance, the Workspace ONE broker service will fail to start.
Validation within vCenter - /var/log/vmware/vmon/vmon.log will show the following errors: level=error msg="runc run failed: unable to start container process: error during container init: error setting cgroup config for procHooks process: bpf_prog_query(BPF_CGROUP_DEVICE) failed: invalid argument" <vc-ws1a-broker> Service pre-start command failed with exit code 1.
The 9.1 precheck script modifies the vCenter 8 container cgroup configuration in the /boot/systemd.cfg file, enabling a unified cgroup hierarchy that is incompatible with the vCenter 8.x container runtime.
To resolve this issue, revert the cgroup configuration to legacy mode:
/boot/systemd.cfg file.systemd.unified_cgroup_hierarchy=yes to systemd.legacy_systemd_cgroup_controller=yes.vc-ws1a-broker, are running using the command: service-control --status --all.