Getting failures for SYSUT1 when installing CA product with CSM
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Getting failures for SYSUT1 when installing CA product with CSM

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Article ID: 44345

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Updated On:

Products

Mainframe Software Manager (Chorus Software Manager)

Issue/Introduction

Problem:

When installing a base package of a CA product with CSM, you can get the next error messages : 

GIM54701S ** ALLOCATION FAILED FOR SYSUT1- IKJ56893I FILE SYSUT1 NOT ALLOCATED+
GIM54701S ** ALLOCATION FAILED FOR SYSUT1- IGD01015I DATA SET ALLOCATION REQUEST FAILED-
GIM54701S ** ALLOCATION FAILED FOR SYSUT1- THE ACS STORAGE GROUP ROUTINE ASSIGNED A
GIM54701S ** ALLOCATION FAILED FOR SYSUT1- DSNTYPE=LARGE DATA SET TO A STORAGE GROUP
GIM54701S ** ALLOCATION FAILED FOR SYSUT1- WHICH IS NOT OF TYPE POOL
GIM47800S ** AN ERROR OCCURRED WHILE GIMUNZIP WAS PROCESSING ARCHIVE CAI.CABA910.F7
GIM20501I      GIMUNZIP PROCESSING IS COMPLETE. THE HIGHEST RETURN CODE WAS12

And at the end you will see the following errors of the failed install:

12.31.02 STC09400IKJ56228I DATA SET SYSP.MSM.MSMTC.P13.SMPMCS NOT IN CATALOG OR CATALOG CAN NOT BE ACCESSED
12.31.03 STC09400IKJ56228I DATA SET SYSP.MSM.MSMTC.P13.CAI.CCSA910.F1 NOT IN CATALOG OR CATALOG CAN NOT BE ACCESSED
12.31.09 STC09400IKJ56228I DATA SET SYSP.MSM.MSMTC.P13.CAI.CCSA910.F2 NOT IN CATALOG OR CATALOG CAN NOT BE ACCESSED
12.31.18 STC09400IKJ56228I DATA SET SYSP.MSM.MSMTC.P13.CAI.CCSA910.F3 NOT IN CATALOG OR CATALOG CAN NOT BE ACCESSED
....

Environment:

z/OS
Chorus Software Manager
Any z/OS CA product enabled to install with CSM

Cause:

The cause of this problem is the code of your ACS routine.
See this message from the log :
 THE ACS STORAGE GROUP ROUTINE ASSIGNED A DSNTYPE=LARGE DATA SET TO A STORAGE GROUP WHICH IS NOT OF TYPE POOL 

In your ACS routines you are probably checking on the program name, like this :
   WHEN (&DSNTYPE = 'LARGE' && &PGM = GIM*)
     SET &STORCLAS = 'SCWORK'
or
   WHEN (&DD='SYSUT1' && &PGM='GIMUNZIP')
   DO
     SET &STORCLAS = 'NONVIO'
     WRITE 'NON-VIO TEMP FILES ARE SMS MANAGED'
   EXIT

Resolution:

With CSM the &PGM variable is not passed. You need to change the ACS routine and remove the &PGM check.
Like this :
  WHEN (&DSNTYPE = 'LARGE')
    SET &STORCLAS = 'SCWORK'
or
   WHEN (&DD='SYSUT1') 
   DO 
     SET &STORCLAS = 'NONVIO' 
     WRITE 'NON-VIO TEMP FILES ARE SMS MANAGED' 
   EXIT

Additional Information:

https://www.ibm.com/support/knowledgecenter/SSLTBW_2.1.0/com.ibm.zos.v2r1.idas200/acslang.htm

Environment

Release: MSMNGR00200-5.1-Chorus Software Manager
Component: