ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

In MSP New driver, when exporting a Project from PPM to MSP, incorrect settings in File-> Options are Exported

book

Article ID: 44324

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Problem

When exporting a project from PPM to MSP, some default settings are not exporting correctly based on what is set for New projects in MSP->File->Options. They appear to be instead exporting from the Microsoft Project out of the box settings. 

Example: If you set 'Default task type' to 'Fixed Duration' in MSP Options, if you export a new project from MSP to PPM and create a new task, the task type will incorrectly be set as Fixed Units. Settings that do not export correctly (if changed from the out of the box settings) include: 

  1. In MSP->File->Options->Schedule: 
  • Week starts on: Sunday 
  • Fiscal year starts in 
  • Default task type 
  • Autolink inserted or moved task 
  • New scheduled tasks have estimated durations 
  • Inserted projects are calculated like summary tasks 
  • Actual costs are always calculated by project 


    2. In MSP->File->Options->Advanced: 

  • Edits to total task % complete will be spread to the status date 
  • Calculate multiple critical paths 

Note: This doesn't occur for all settings, some that do retain the information set for new projects include:

  • Updating Task status updates resource status. If you uncheck this setting, it will remain unchecked when exporting a project to PPM
  • New Tasks created: If you change this to Autoscheduled, it will be retained when opening new projects 

Steps to Reproduce

  1. Open Microsoft Project 
  2. Close all projects in MSP, including any blank projects such as 'Project 1' so settings made are applied for all new projects 
  3. Go to File->Options->Schedule and set the following (make sure all settings are for "All New Projects"
  • Week starts on: Monday (this should be pulling from a PPM Setting, but this change it to show that it is not pulling from MSP Settings as well) 
  • Fiscal year starts in: February 
  • Default Task Type: Fixed Duration 
  • Autolink inserted or moved tasks: Checked 
  • New scheduled tasks have estimated durations: Unchecked 
  • Under Calculation options for this project: 
  • Inserted projects are calculated like summary tasks: Unchecked 
  • Actual costs are always calculated by Project: Unchecked 

     4. In File->Options->Advanced make the following changes: 

  • Edits to total task % complete will be spread to the status date: Checked 
  • Calculate multiple critical paths: Checked 

     5. Click OK to set these changes for All New Projects 
     6. In PPM, In Administration->Project Management->Settings

  • Change 'First Month of Financial Quarter' to 'Mar'
  • Change 'First Day of Work Week' to 'Tue' 
     7. Click Save
     8. Create a new project in PPM (no tasks/team members needed) 
     9. Export the project to MSP 
      10. Go to File->Options->Schedule and then File->Options->Advanced and observe the results
 
Expected Results: All settings made for new projects in MSP are reflected in project exported from PPM (with the exception of Week starts on: that should be pulling from PPM in Project Management Settings)
 
Actual Results: Some settings are exported incorrectly and do not match the changes made in MSP Options
 
In Schedule: 
  • Week starts on: Sunday (should be Tuesday pulled from PPM, In Administration->Project Management->Settings)
  • Fiscal year starts in shows January (This is incorrect, it should either be February if pulled from MSP settings, or March if pulled from PPM (Administration->Project Management->Settings First month of Financial quarter)
  • Default task type: Fixed Units (should be Fixed Duration)
  • Autolink inserted or moved tasks is unchecked (Should be unchecked)
  • New scheduled tasks have estimated durations is unchecked (should be checked)
  • Inserted projects are calculated like summary tasks is checked (Should be unchecked)
  • Actual costs are always calculated by project is checked (Should be unchecked)

In Advanced:

  • Edits to total task % complete will be spread to the status date is unchecked (should be Checked)
  • Calculate multiple critical paths: Unchecked (should be Checked) 

Environment: 

Applies to the MSP Interface New Driver for all supported releases of PPM and Microsoft Project

Cause: 

This is caused by defect CLRT-80681

 

Resolution:

This issue has been resolved as of CA PPM 14.4 Patch 3 and PPM 15.1 Patch 1.

 

Workaround:

  • Option 1: If the project is first created in PPM, export the project from PPM to MSP and update all the settings in MSP->Options. Save the project back to PPM, then each time you export the project after that from PPM to MSP, the settings will be correct. 
  • Option 2: Create the project first in MSP and use Save As to create a new project in PPM. The settings will be correct each time you export the project from PPM.

 

Additional Information:

Reference the CA Clarity PPM Integration Best Practices for Microsoft Project for required and recommended settings when integrating with MSP.

Environment

Release: 451-101-14.4-Clarity-Creator User License
Component: