Stateful ESXi 9.0 Auto Deploy Fails to Add Host in vCenter due to Missing Certificate Path
search cancel

Stateful ESXi 9.0 Auto Deploy Fails to Add Host in vCenter due to Missing Certificate Path

book

Article ID: 443163

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Hosts provisioned via Stateful Auto Deploy fail to join the vCenter Server inventory automatically
  • Post the host installation is complete, manually adding the host to vCenter Server is successful
  • This issue is seen on ESX 9.0 only
  • /var/log/vmware/rbd/rbd-syslog.log: (on vCenter)

YYYY-MM-DDTHH:MM:SS warning rbd  [2122999]addhost:WARNING:Host(<ESXi IP>) currentTime : YYYY-MM-DD HH:MM:SS+00:00
YYYY-MM-DDTHH:MM:SS err rbd  [2122999]sslutil:ERROR:Certificate path is missing for host with id:<host ID> and moRef:None

  • /var/log/vmware/rbd/rbd-cgi.log: (on vCenter)

YYYY-MM-DDTHH:MM:SS [2122999:Thread-5 (process_request_worker)]INFO:beacon:Sorting the list with IPv4 addresses first.
YYYY-MM-DDTHH:MM:SS [2122999:Thread-5 (process_request_worker)]INFO:beacon:Adding etc/vmware/autodeploy/waiterNotify.json
YYYY-MM-DDTHH:MM:SS [2122999:Thread-5 (process_request_worker)]INFO:cache_tables:cache request -- {'plugin': 'initialdeploy', 'src_name': '<host ID>', 'src_vc_id': 1}
YYYY-MM-DDTHH:MM:SS [2122999:Thread-5 (process_request_worker)]INFO:sslutil:cert files are missing from /var/lib/rbd/ssl/<host ID>

Environment

ESX 9.0

Cause

The issue is a result of a race condition triggered by Host Profile configurations if the attached profile includes Distributed Virtual Switch (DVS)

Resolution

Broadcom Engineering is aware of the issue and is working towards a permanent fix for this issue.

Proceed to Contact Broadcom support for assistance.