Install Identity Broker using Fleet Lifecycle
Failed
Description Install Identity Broker using Fleet Lifecycle
Progress Messages The Fleet lifecycle 'VSP component installation' task with ID <subtask ID> failed. Internal errors: The resolved IP address <IP address> from the FQDN <Identity broker FQDN> is already in use.
Error
Message: The Fleet lifecycle 'VSP component installation' task with ID <subtask ID> failed. Internal errors: The resolved IP address <IP address> from the FQDN <Identity broker FQDN> is already in use.ERROR [vcf_dm,<OP ID>,ad1a] [c.v.e.s.o.model.error.ErrorFactory,dm-exec-31] [IFCN5A] PUBLIC_FLEET_LCM_TASK_FAILED The Fleet lifecycle {0} task with ID <ID> failed. Internal errors: The resolved IP address <IP Address> from the FQDN <Identity broker FQDN> is already in use.
com.vmware.evo.sddc.orchestrator.exceptions.OrchTaskException: The Fleet lifecycle {0} task with ID <ID> failed. Internal errors: The resolved IP address <IP Address> from the FQDN <Identity broker FQDN> is already in use.
DEBUG [vcf_dm,<OP ID>,28fc] [c.v.e.s.o.c.c.ContractParamBuilder,dm-exec-47] Contract task InstallVspComponentFleetLcmAction input: {"_executionUuid":"<execution_ID>","componentSpec":{"deploymentType":"VspComponentSpec","sddcLcmId":"<LCM OP ID>","componentType":"VIDB","version":"9.1.0.0.25368698","repository":{"downloadUrl":"https://<Identity broker FQDN>/vmware/vcf/bundle/<bundle ID>/<bundle ID>/vidb-9.1.0.0.25368698.tgz"},"fqdn":"<Identity broker FQDN>","componentNamespace":"vidb-external","configSpec":{"size":"small","ipAddresses":[]}}}VMware SDDC Manager / VCF Installer
vcf.vault.http-access=true under application-prod.propertiesecho vcf.vault.http-access=true >> /etc/vmware/vcf/domainmanager/application.properties && systemctl restart domainmanager
Note: After the workflow completes successfully, delete the property vcf.vault.http-access=true from /etc/vmware/vcf/domainmanager/application-prod.propertiescurl -X GET http://localhost/domainmanager/internal/vault/<execution_uuid> | json_pp > /tmp/workflow.jsonNote: execution_uuid is captured from domainmanager.log
Sample:- input: {"_executionUuid":"<execution_ID>"
/tmp/workflow.json and replace instances of the incorrect Identity Broker FQDN with a new & unique FQDN
DeployOrJoinVcfManagementComponents____##DeployVidbFleetLcm##__componentSpec
DeployOrJoinVcfManagementComponents____##__vcEndpoint
vidbSpec
vidbcurl -H 'Content-Type:text/plain' -X PUT http://localhost/domainmanager/internal/vault/<execution_uuid> -d @/tmp/workflow.jsonvi /etc/vmware/vcf/domainmanager/application-prod.propertiesfleetlcm.task.id.to.recreate=<Task_ID from step c>systemctl restart domainmanager