Error: Microsoft Store Request Timeout in Microsoft Store Import wizard with proxy
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Error: Microsoft Store Request Timeout in Microsoft Store Import wizard with proxy

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Article ID: 442987

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Updated On:

Products

IT Management Suite Software Management Solution

Issue/Introduction

When attempting to use the Microsoft Store Import wizard in ITMS 8.8.1 with a proxy server configured in Notification Server Settings, the search function fails. Regardless of the search query entered, the console displays the following error:

Microsoft Store Request Timeout

The following or similar errors may be observed in the SMP Logs:

"Cancelling the search request due timeout","AppSearchEngine.Search","Altiris.SoftwareManagement.dll","1736","Warnings"

"Failed to retrieve app search for product <search string>, HTTP Request timeout.","dlgImportMsStore.RenderTimeoutAndErrors","Altiris.SoftwareManagement.Web.dll","1736","Warnings"

Environment

 

  • Product: IT Management Suite (ITMS), Software Management Solution

  • Version: 8.8 and 8.8.1

  • Configuration: A proxy server is enabled under Settings > Notification Server > Notification Server settings > Proxy tab

Cause

An adjustment to the Notification Server's proxy configuration was necessary to mitigate request timeouts.

A Point fix has been released to address this issue in 8.8.1

Resolution

  1. Access the SMF 8.8.1 Point Fixes at the following link: 433118.

  2. Download the SMF 8.8.1 Point Fix.

  3. Follow the instructions contained in the Readme.pdf inside the attachment.