VcManager <VC-FQDN>: The vCenter Server should not be in ELMRemediation: Remove the vCenter Server from the ELM ring
/var/log/vmware/vcf/domainmanager/domainmanager.log shows entries similar to:{"errorCode":"BROWNFIELD_VSPHERE_CHECK.error","arguments":["vCenter Server is in ELM","VcManager <VC-FQDN>: The vCenter Server should not be in ELM","Remove the vCenter Server from the ELM ring"],/var/log/vmware/vapi/endpoint/endpoint.log shows entries similar to:YYYY-MM-DDThh:mm:ss | ERROR | vAPI-I/O dispatcher-0 | SessionFacade | 6c3af22b-403b-9c65-ae6d-3b12d41f96bd | Unexpected error occurred while executing the call with session [email protected] (internal id 9291fb21) for method com.vmware.vcenter.topology.nodes.list.
com.vmware.vapi.client.exception.TransportProtocolException: HTTP response with status code 503 (enable debug logging for details): upstream connect error or disconnect/reset before headers. reset reason: connection termination
/var/log/vmware/trustmanagement/trustmanagement-svcs.log shows entries similar to:YYYY-MM-DDThh:mm:ss [tomcat-exec-285 [] ERROR com.vmware.vapi.protocol.server.msg.json.JsonServerConnection opId=] Severe internal errorjava.lang.OutOfMemoryError: Java heap space
/usr/lib/vmware-vmdir/bin/vdcrepadmin -f showservers or /usr/lib/vmware-vmafd/bin/dir-cli nodes list on vCenter Server confirms only one node exists in the SSO domain.VCF 9.1
This issue is caused by an OutOfMemoryError condition affecting the vmware-topologysvc service on the vCenter Server. As a result, requests to the com.vmware.vcenter.topology.nodes.list API fails, returning HTTP response with status code 503 errors during the VCF vCenter import workflow, which leads to the import task failure.
To resolve this issue, you must ensure the vCenter vAPI services are healthy and responsive before retrying the validation.