"Failed to connect to VMware depot with the provided user credentials. Cause: {0}."
/var/log/vmware/vcf/lcm/lcm-debug.log file contains the following exception: "sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested targetA"
curl -kv https://dl.broadcom.com may succeed (due to the -k insecure flag), but a standard curl or openssl connection fails with certificate validation error.VMware Cloud Foundation
SDDC Manager.
dl.broadcom.com, the network security device intercepts the SSL traffic and replaces the original Broadcom/DigiCert certificate with its own CA certificate. Since the certificate authority used by the inspection device is not trusted by the SDDC Manager's Java trust store, the SSL handshake fails and the connection is blocked as a security precaution against potential Man-in-the-Middle (MitM) attacks.Follow the steps below to configure the SDDC Manager to trust the intercepting network appliance:
openssl s_client -connect dl.broadcom.com:443 -showcerts /tmp/root_chain.cer) using an SCP utility.pass=$(cat /etc/vmware/vcf/commonsvcs/trusted_certificates.key)keytool -importcert -alias new_mgmt_root -file /tmp/root_chain.cer -keystore /etc/vmware/vcf/commonsvcs/trusted_certificates.store -storepass $passkeytool -importcert -alias depot_root -file /tmp/root_chain.cer -keystore /etc/alternatives/jre/lib/security/cacerts --storepass changeitkeytool -list -v -keystore /etc/vmware/vcf/commonsvcs/trusted_certificates.store -storepass $pass | lesscurl -X POST localhost/appliancemanager/trustedCertificates/refresh
Alternative Workaround:
Reach out to the Network Security team to implement an SSL Decryption Bypass (Whitelist) for the domain dl.broadcom.com. This allows the SDDC Manager to receive the original trusted certificate directly from Broadcom, bypassing the need for manual certificate imports.