Service Accounts are not visible from the vSphere Client UI
search cancel

Service Accounts are not visible from the vSphere Client UI

book

Article ID: 442650

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Service Accounts (formerly Solution Users) are no longer visible and cannot be managed from the vSphere Client UI.

Environment

VMware vCenter 9.x

Cause

This is an intentional design change to enhance security and prevent accidental modifications.

Resolution

No action is required. The system automatically manages service accounts in the background, including automatic password rotation and the removal of unused accounts.

Although not visible in the UI, you can still list the existing Service Accounts using the CLI. 

Run the following command on the vCenter appliance:

/usr/lib/vmware-vmafd/bin/dir-cli svcaccount list --login [email protected] --password '<password>'