CNF Instantiation is failing on creating the namespace
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CNF Instantiation is failing on creating the namespace

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Article ID: 442544

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Updated On:

Products

VMware Telco Cloud Automation VMware Telco Cloud Platform

Issue/Introduction

When attempting to instantiate or terminate a Cloud Native Function (CNF) in VMware Telco Cloud Automation (TCA), the workflow fails during the namespace creation or 'Clean up' steps.

  • TCA UI displays: CNF130005 (Unauthorized) or Internal Server Error during the 'Clean up' task.
  • TCA-CP app logs show 401 Unauthorized responses when attempting to communicate with the registered vRealize Aria Orchestrator (vRO) endpoint.
  • The vRO endpoint status in the TCA-CP management interface (port 9443) may show as 'Disconnected' .

Environment

TCA build : 3.2, 3.3, 3,4
TCP : 5.0, 5.0.1, 5.1

Cause

The root cause is a broken authentication connection state between the TCA-CP manager and its associated vRO instance. TCA-CP fails to retrieve the required native workflow (name=SSH Command) from the vRO inventory due to an HTTP 401 Unauthorized condition. This  is caused by the vRO appliance becoming inaccessible or unstable which prevent the execution of SSH-based guest commands required for CNF workflows.

Resolution

Please open ticket to resolve the vRO issue.

Once the vRO issue is resolved. Verify the connection status of the vRO with the TCA-CP appliance:

  1. Log in to the VMware Telco Cloud Automation-Control Plane (TCA-CP) appliance management interface.

  2. Navigate to the vRealize Orchestrator configuration section.

  3. Verify the connection status shows as connected.

  4. Re-run the CNF workflow to confirm the CNF instantiation completes successfully.