VCF 9.1 Supervisor Content Library fails with 'Invalid response code: 403'
search cancel

VCF 9.1 Supervisor Content Library fails with 'Invalid response code: 403'

book

Article ID: 442430

calendar_today

Updated On:

Products

VMware vCenter Server VMware vSphere Kubernetes Service

Issue/Introduction

On a new installation of VMware Cloud Foundation (VCF) 9.1, after successfully installing the Supervisor, multiple failed tasks are observed for the Kubernetes Service Content Library.

The vCenter Server tasks show errors similar to:

  • A general system error occurred: Error retrieving files for library item [UUID]. Reason: ubuntu-ova-disk1.vmdk: source error: Invalid response code: 403
  • ubuntu-ova.ovf: source error: Invalid response code: 403
  • The subscribed content library shows a different content library than "https://wp-content.broadcom.com/supervisor/v1/latest/lib.json

Environment

VCF 9.1

VKS (vSphere Kubernetes Service)

Cause

Starting in 9.x, the repository URLs have been updated.

Resolution

Contact Broadcom support for further assistance. 

 

Workaround: