Unable to configure Identity Broker in VCF Operations due to Internal server error
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Unable to configure Identity Broker in VCF Operations due to Internal server error

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Article ID: 442427

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Updated On:

Products

VCF Operations

Issue/Introduction

When you attempt to configure the Identity Broker in VCF Operations, the configuration fails. You observe the following error messages in the user interface:

Sorry we have encountered an error, Error message: Internal server error, Cause unknown.
There was a problem identity broker data. Some of the state may not be displayed properly

Environment

VCF Operations 9.1

Cause

This issue occurs due to a DNS configuration problem on the Cloud Proxy (CP). The Operations CP must be in a working state to configure the Identity Broker for VCF instances. If the CP is deployed with a temporary DNS server that cannot resolve necessary external internet FQDNs, the HA proxy service fails to start, leaving the CP offline.

Resolution

To resolve this issue, correct the DNS configuration on the Cloud Proxy:

  1. Update the DNS server settings on the Cloud Proxy from the temporary DNS server to a permanent DNS server.

  2. Ensure the new DNS server can successfully resolve required internet FQDNs (for example, Broadcom API endpoints).

  3. Verify that the HA proxy service starts successfully on the CP and that the CP comes online.

  4. Retry configuring the Identity Broker in VCF Operations.