Lifecycle manager is missing after Vcenter upgrade from 8.0.3 to 9.0.2 or 9.1
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Lifecycle manager is missing after Vcenter upgrade from 8.0.3 to 9.0.2 or 9.1

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Article ID: 442418

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Customer upgraded vCenter from 8.0.3 up to 9.0.2 or 9.1 and after upgrade is complete can't see the Lifecycle Manager in the UI.

vsphere_client_virgo.log has entries indicating it is unable to register the LCM plugin due to permissions.

YYYY-MM-DDTHH:MM:SS.000Z INFO vsphere-ui 75 [vc@4413 threadName="pool-2-thread-1" logger="com.vmware.vise.plugin.registration.VcExtensionRegistrarImpl"  ] Registering extension 'com.vmware.vsphere.update.manager.client' version '9.1.0.0' with VC <VC_UUID>.
YYYY-MM-DDTHH:MM:SS.000Z ERROR vsphere-ui 75 [vc@4413 threadName="pool-2-thread-1" logger="com.vmware.vise.plugin.registration.VcExtensionRegistrarImpl"  ] Failed to register extension 'com.vmware.vsphere.update.manager.client' version '9.1.0.0' with VC <VC_UUID>.
YYYY-MM-DDTHH:MM:SS.000Z ERROR vsphere-ui 75 [vc@4413 threadName="pool-2-thread-1" logger="com.vmware.vise.plugin.registration.VcExtensionRegistrarImpl"  ] Failed to register extension com.vmware.vsphere.update.manager.client with VC <VC_UUID> com.vmware.vim.binding.vim.fault.NoPermission: Permission to perform this operation was denied.

YYYY-MM-DDTHH:MM:SS.000Z WARNING vsphere-ui 189 [vc@4413 threadName="vum-ui-registration" logger="com.vmware.vum.client.registration.RegisterVumUiRemotePlugin"  ] Exception while processing plugin registration java.util.concurrent.ExecutionException: (vim.fault.NoPermission) {
   faultCause = null,
   faultMessage = null,
   object = ManagedObjectReference: type = Folder, value = group-d1, serverGuid = <VC_UUID>,
   privilegeId = Extension.Register,
   missingPrivileges = (vim.fault.EntityPrivileges) [
      (vim.fault.EntityPrivileges) {
         dynamicType = null,
         dynamicProperty = null,
         entity = ManagedObjectReference: type = ExtensionManager, value = ExtensionManager, serverGuid = <VC_UUID>,
         privilegeIds = (STRING) [
            Extension.Register
         ]
      }
   ]
}

Caused by: com.vmware.vim.binding.vim.fault.NoPermission: Permission to perform this operation was denied.

Environment

vCenter 9.x

Cause

Permissions got inadvertently set prior to the upgrade, or as part of the upgrade process causing the account to be set to read only level permissions.  Since vCenter works under the most restrictive policy those read-only permissions override the normal set permissions.

Resolution

  • Log into the vSphere Web Client and go to the hosts and clusters view.
  • Click the Permissions tab and search for the vsphere-webclient user and confirm the permissions assigned.  (Should be Role: "vSphere Client Service Account"  Defined in: "Global Permission")
  • If they show anything else, the permissions will need to be corrected.

 

  1. Take a snapshot of the vCenter to make sure you can roll back if needed.
  2. Select the vsphere-webclient user and remove it from the Permission tab from the vCenter server object.  It should revert back to the correct Global Permissions.
  3. Once the permissions of the account are correct the system should be able to register properly and the UI will show the LCM correctly.