Direct port connection error in Tunnel client server hub log
search cancel

Direct port connection error in Tunnel client server hub log

book

Article ID: 44241

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

In some scenarios a Tunnel client server's hub.log may display communication errors with other Tunnel client server via port 48002 even though Tunneling is properly set and is successfully communicating with it's Tunnel server.

Example of error seeing in hub.log with loglevel 3.

sockConnect - connect to 1.1.1.1 48002 failed 10060
ihubrequest: SessionConnect failed: 1.1.1.1/48002
hub: hubup - send failed for /UIMDomain/OtherTunnelClientHubName (1.1.1.1:48002 communication error)

 

 

Environment

UIM with Hubs that have "Enable Tunneling" configured.
 

Cause

Hubs trying to learn about other hubs in UIM

Resolution

1. Stop the hub robot services on the systems included in the communication error
2. Set the broadcast_on value to no in the X:\Nimsoft\hub\hub.cfg file
    Example:
    broadcast_on=no
3. Reset the Hub's X:\Nimsoft\hub\hub.sds file
    Delete the X:\Nimsoft\hub\hub.sds file
4. Start the hub robot services
5. Confirm that the hub.log no longer shows the communication error