SCCM connector fails on import 500_sccm_inv_raw_arp.xml

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Article ID: 4424

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Updated On:

Products

CA IT Asset Manager CA Software Asset Manager (CA SAM) ASSET PORTFOLIO MGMT- SERVER CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

While running the 500_sccm_inv_raw_arp.xml; an error is recieved:

"Conversion failed when converting date and/or time from character string."

 

Cause

The import fails because SCCM has different types of date format stored on InstallDate0. 

Environment

All

Resolution

There are some non-US systems in SCCM and their install date is recorded slightly different on those systems. Our OOTB connector cannot handle that difference and would need some work to correct.

The immediate solution is to just comment out lines where this is referenced (date). Missing this data will not impact any compliance calculations.

 

 

(example below)

Put /* before CASE and follow with */ immediately after END AS installation_date

You will also need to remove the comma after the line right before CASE

 

Looks like this....

 

newestDevices.Netbios_Name0 AS import_device_id [comma removed from this line]

 

/*

CASE

Stuff

END AS installation_date

*/