Could not save user '<user>' in AccountAdmin in DX UIM OC
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Could not save user '<user>' in AccountAdmin in DX UIM OC

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Article ID: 442359

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

You are attempting to create a specific user accounts in the Operator Console under Administration > Account Administration. When trying to save a user ID it generates an error: 

Could not save user '<user>'

This behavior is inconsistent - some users can be created some others have this error.

 

Environment

DX UIM 23.4.* 

Cause

The error occurs because a "Nimbus user" with the same name already exists in the system. The Operator Console Account Administration tool fails to save the new user because it detects a duplicate identity already present in the Nimsoft runtime environment.


The following error might appear in wasp.log:

May 24 08:55:56:648 ERROR [http-nio-80-exec-4, com.firehunter.ump.exceptions.DataFactoryException] hub user already exists: <user>
May 24 08:55:56:648 ERROR [http-nio-80-exec-4, com.firehunter.ump.exceptions.DataFactoryException] 
May 24 08:55:56:648 ERROR [http-nio-80-exec-4, com.firehunter.ump.exceptions.DataFactoryException] java.lang.Throwable: hub user already exists::  <user>

Resolution

To resolve the issue Ensure that the login ID being created in Account Administration does not conflict with any existing "real" Nimsoft users or Bus users already defined in the primary hub security settings.

Steps to check duplicates: 

  1. Log into Infrastructure Manager.

  2. Navigate to Security > User Administration.

  3. Search for the login ID that is failing in the Operator Console.

Additional Information

Related Documentation: DX Unified Infrastructure Management / UIM Users Explained