CA 7 task cancellation due to ACF2 MAXVIO security violations
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CA 7 task cancellation due to ACF2 MAXVIO security violations

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Article ID: 442287

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Updated On:

Products

CA 7 Workload Automation

Issue/Introduction

The CA 7 started task abends or crashes during startup or operation. This occurs because the security environment detects multiple access violations and triggers a task cancellation based on its global security settings.

Environment

Release: 12.0, 12.1

Component: WA CA 7 Edition

Cause

ACF2 cancels the started task once it reaches the maximum number of allowed violations (MAXVIO). This frequently happens on load libraries (e.g., HLQ.####.LOADLIB) or parameter libraries (e.g., HLQ.####.PARMLIB).  

Resolution

To resolve this issue and prevent the started task from crashing, there are three possible options:

Option 1: Grant Access to the Datasets. Add the security rules to grant the started task's logonid the required access. The following syntax to update the rules:

ACF
SET RULE
RECKEY #### ADD(D.- UID(uid string of user) READ(A) EXEC(A))

Option 2: Enable NOMAXVIO for the Logonid. If the task must continue running even if violations occur, assign the NOMAXVIO attribute to the logonid. This allows normal validation to occur but prevents ACF2 from canceling the task.

SET LID
CHANGE Logonid NOMAXVIO

Note: You must restart the started task after making this change.

Option 3: Increase the Global MAXVIO Limit If prefer not to use NOMAXVIO, increase the global violation threshold. Perform this by updating the global MAXVIO count in your GSO OPTS record.

Additional Information

Direct ACF2 to check that the submitting logonid has the authority to submit batch jobs. Refer to the tech docs link below for more info on submitting batch jobs:
 
Access rule procedures grant access to data sets and programs on the system based on the fields in logonids. Refer to the tech docs link below for more info on Access rule procedures: