Persistent "NotAuthenticated" alerts for INFRASTRUCTURE_POLICY in VMware Data Services Manager
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Persistent "NotAuthenticated" alerts for INFRASTRUCTURE_POLICY in VMware Data Services Manager

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Article ID: 442269

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Updated On:

Products

VMware vCenter Server VMware Data Services Manager

Issue/Introduction

  • Periodic (e.g., weekly) warning emails from VMware Data Services Manager (DSM) reporting authentication failures are received, even when database operations and provisioning appear normal.
  • The following entry related to the alert is observed in the monitoring.log file of the DSM:

YYYY-MM-DD HH:MM:SS.###  INFO [db-informer-10 ] c.v.t.s.c.a.AlertServiceImpl   - __INIT__ processSystemAlert AlertDTO {target name =[DSM-name], target id =########-####-####-####-############, createdTimestamp=2026-03-14 01:45:15.435721632, alertType=INVALID_INFRASTRUCTURE_POLICY_STATUS, alertLevel=WARNING, message='error reading datacenter '[DATACENTER_NAME]': NotAuthenticated', namespace='null', primary recipients ='[USER]}, target : INFRASTRUCTURE_POLICY, ########-####-####-####-############, [DSM-name]

  • The alert typically contains the following details:

TargetType: INFRASTRUCTURE_POLICY

Target-name: DSM-name

Name: Invalid InfrastructurePolicy status

Level: WARNING

Description:  Invalid InfrastructurePolicy status

Time: YYYY-MM-DD-HH-MM

Message: error reading datacenter '/[DATACENTER_NAME]': NotAuthenticated

Environment

DSM 9.0.x

vCenter 8.0 U3

Cause

This issue is caused by a condition in DSM 9.0.2 related to a stale vCenter session cache. DSM may attempt to use an unauthenticated or expired vSphere session token, raising an automated email alert. This can be triggered by session TTL expiration or a vCenter reboot, which invalidate existing sessions.

Resolution

The vCenter session cache issue is scheduled to be resolved in DSM version 9.1.1.