CP terminate abnormally after database reconnect in version 24.4.4.
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CP terminate abnormally after database reconnect in version 24.4.4.

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Article ID: 442229

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation Automic Automation

Issue/Introduction

Automation Engine  Communication Processes (CP) randomly terminate during a database reboot or a datacenter switch. This issue is a regression from version 21, where the processes remained stable during such events. 

Observed symptoms include:

  • Processes shut down unexpectedly following a successful database reconnection.
  • Log messages indicate: Socket call 'recv' returned error code '104'. Connection reset by peer.
  • Subsequent logs show: Connection to Server 'SYSTEM#CP009' has been closed followed by Server '...' version '24.4.4' ended abnormally.
  • Java-based processes (JWP/JCP) and Agents are not affected and remain active.

Environment

  • Product: Automic Automation Engine
  • Version: 24.4.4

Cause

This behavior is identified as a software defect where the non-Java processes fail to correctly handle their state after the database session is reset during a failover or reboot. While similar issues were addressed in previous versions (e.g., DE182215), a new defect has been identified in version 24.4.4 under investigation as DE202293.

Resolution

Engineering is currently investigating the root cause for version 24.4.4. To maintain system stability in the interim, follow these steps:

  1. Manual Restart: Manually restart any WP or CP processes that terminate following a database event.
  2. Monitoring: Monitor for the release of an upcoming Hotfix or Service Pack containing the fix for defect DE202293.

Update to a fixed version listed below or a newer version if available.

Automic Automation Engine24.4.5 - TBA

Automic Automation Engine 26.1.0 - TBA

Additional Information

Article title: How to register to Broadcom Software Product updates and Critical Alerts

https://knowledge.broadcom.com/external/article?articleId=133819