VCF 9.0.2 binary download stuck with status of “IN_PROGRESS” for the Fleet Manager
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VCF 9.0.2 binary download stuck with status of “IN_PROGRESS” for the Fleet Manager

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Article ID: 442110

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Updated On:

Products

VCF Operations

Issue/Introduction

  • Preparing for upgrade of Workload domain. Many other binaries downloaded at the same 9.0.2 but the "vrops" download got stuck.

  • Followed steps from KB Fleet Manager binary download Stuck in IN_PROGRESS State from VCF Operations.

    • Performed multiple attempts of running the API commands. GET is functioning properly but POST is receiving error, not allowing status field to be updated from “IN_PROGRESS” to “DOWNLOADED”.

Environment

VCF 9.0.2

Cause

  • If there is any binary download request stuck, there is no delete option for the user. In the VCF Operations UI there is no workaround for the user to start the download again.

  • VCF Ops Fleet Manager ran out of storage space which led to this download failing and getting stuck “IN_PROGRESS”.

Resolution

Confirm sufficient storage space is available for the Fleet Manager to download packages

 

Clear the "IN_PROGRESS" status of failed package download via API

  1. Retrieve base64 encoded password to use in below API command. From KB How to update the VCF 9 Automation password.


    echo -n 'admin@local:<youradminatlocalpassword>' | base64

  2. Gather the necessary details to run the API command
    1. While logged into the VCF Operations management portal, navigate to "Fleet Management > Lifecycle > VCF Management > Binary Management > Install Binaries"
    2. Right click the page and select "Inspect".
  3. In the new windows that pops up select the "Network" tab and then the "Response" tab.
    1. Within the JSON section find the package needing to be cancelled and copy the full details of it.
  4. Run the API command to remove hung package download task.

    curl -k -X POST "https://<FleetManager_fqdn_or_IP>/lcm/lcops/api/settings/productbinarydelete" \
    -H "Authorization: Basic <base64_encoded_password_from_above_goes_here>" \
    -H "Content-Type: application/json" \
    -d '{<JSON_data_collected_above>}'

    Example:

    curl -k -X POST "https://<FleetManager_fqdn_or_IP>/lcm/lcops/api/settings/productbinarydelete" \
    -H "Authorization: Basic <base64_encoded_password>" \
    -H "Content-Type: application/json" \
    -d '{
      "productId":"vrops",
      "productVersion":"9.0.0.0",
      "productBinaryType":"Install",
      "productBinaryPath":"Operations-Appliance-9.0.0.0.24695812.ova",
      "componentName":null,
      "mappingType":null,
      "productName":"operations",
      "requestId":null,
      "removeBinary":null,
      "depotType":null,
      "DownloadStatus":"IN_PROGRESS",
      "patchId":null,
      "size":"2 GB",
      "releaseDate":"17 June 2025"
    }'
  5. Confirm the download is no longer listed.
  6. Attempt download again.

Additional Information

Our engineering team is aware of this issue and is actively working on a fix. This should be implemented in a later build.