Getting Warning pop-ups to reload tab / window when using multiple tabs
search cancel

Getting Warning pop-ups to reload tab / window when using multiple tabs

book

Article ID: 442069

calendar_today

Updated On:

Products

VCF Automation

Issue/Introduction

  • When you use multiple browsers or tabs, you may randomly receive a warning pop-up prompting you to reload the tab or window.
  • You may have separate tabs open for Assembler, Orchestrator and/or Service Broker
  • If you are entering details when this occurs, the entered information is lost.
  • Using a unique User ID, i.e., an ID not shared with any other person, when there are multiple browser tabs, in the same browser window, open and accessing VCF Automation, it frequently pops-up the following message:

Environment

VCF Automation9.0.x versions prior to 9.1

Cause

This issue is caused by a problem with session token renewal. Even if other tabs are active, an idle tab will still attempt to refresh the token, which forces all open tabs to refresh as well.

Resolution

Fixed in release 9.1 and higher. See Download Broadcom products and software for steps to download this release.

Additional Information

 

  • In version 9.1, the product is fixed as it no longer uses local storage to maintain access tokens across browser tabs.

  • Each browser tab now maintains its own access token in memory and relies on an HttpOnly cookie to retrieve the same user session from the backend across browser tabs.