Error SDM228482 when deploying a package to UNIX machines
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Error SDM228482 when deploying a package to UNIX machines

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Article ID: 44203

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

Deploying packages to unix machines results in the following error for some of the deployments even though the machines have plenty of free disk space:
 
"Job execution error, no access to the software package library, native OS error:28 - No space left on device [SDM228482]"

Environment

Client Automation - 14.x

Cause

Cause 1 :
 
The default temporary location that software delivery uses during the package install process does not have enough free space.
By default UNIX agents use the SDROOT environment variable. If you run "echo $SDROOT on UNIX it will give you the path.
Within there is a /tmp directory that is used.
 
Cause 2 :
 
Client Automation Agent is installed on a file system which has more than 1 TB of free disk space.
In SD Agent logs there are a negative freeKB number :
|SDAgent||sdjeunixharddriveif.|000075|INFO   | Path=/opt/CA/DSM/sd/tmp,reqSpace=19
|SDAgent||sdjeunixharddriveif.|000094|INFO   | freeKB=-1049684733,reqSpace=19
|SDAgent||sdjeasmlibraryif.cpp|000118|ERROR  | There is NOT enough available disk space
|SDAgent||sdjecontainerif.cpp |001081|NOTIFY | RequestAccess failed for library 1

Resolution

The following command can be run on the UNIX machine to reset the tmp path used for deployments:
 
ccnfcmda -cmd SetParamterValue -ps itrm/usd/shared -pn insttemppath -v <new location>
 
In this example, is set a path which has enough free disk space (cause 1) or with less free disk space than 1 TB
 
ccnfcmda -cmd SetParamterValue -ps itrm/usd/shared -pn insttemppath -v /tmp/agentsd