VCF Operations for Logs Flooded with "Error occurred while initialising Provider and Discoverer"
search cancel

VCF Operations for Logs Flooded with "Error occurred while initialising Provider and Discoverer"

book

Article ID: 442017

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • VCF Operations for Logs experiences log flooding with repeated initialization error messages from the orchestrator.

  • The following error signature is continuously observed in the vCenter Server vstats logs :

    /var/log/vmware/vstats/vstats-stdout.log

ERROR discovery/manager.go:88 Error occurred while initialising Provider and Discoverer for {"vStats": "MVP", "rsrcType": "HOST", "error": "No discovery config found for HOST"}

Environment

VCF Operations for Logs 9.0
VCF 9.0

Cause

VCF Operations for Logs subscribes to HOST resource metrics, but the HOST provider configurations on the vCenter Server lack the required discoveryConfig. Consequently, the orchestrator continuously attempts to restart the HOST discovery process.
Because there is currently no de-duplication mechanism for this specific event, each failed initialization attempt forwards an error to VCF Operations for Logs, resulting in a flooded log state.

Resolution

This issue will be resolved in VCF 9.1.1 release. There is currently no workaround required as this is a cosmetic log flooding issue that does not impact core logging functionality.