ServiceEngineGroup upgrade to 31.2.2 will fail if enough production licenses are not available
search cancel

ServiceEngineGroup upgrade to 31.2.2 will fail if enough production licenses are not available

book

Article ID: 441975

calendar_today

Updated On:

Products

VMware Avi Load Balancer

Issue/Introduction

Upgrade to 31.2.1 or 31.2.2 will fail if purchased licenses fall short of required licenses. Error like this will be shown in Controller shell CLI only - "show upgrade status detail filter pre_check_status"

Environment

Avi 31.2.x and later 

Cause

Trial licenses will not be counted as valid licenses for upgrade in 31.2.x release and later

Resolution

Add sufficient licenses to continue with SEG upgrade

 

Upgrade checklist has documentation note - https://techdocs.broadcom.com/us/en/vmware-security-load-balancing/avi-load-balancer/avi-load-balancer/31-2/vmware-avi-load-balancer-release-notes/checklist-for-upgrade-to-31-2-x.html

  • Before upgrading to 31.2.1 ensure that you have the required number of production licenses. On upgrading without the requisite number of licenses, activation of new Service Engines will fail. A pre-check has been added in 31.1.1 to prevent upgrades. However, upgrade from earlier versions should be verified manually prior to upgrade.