AWI unavailable, ucybsmcl throws "No route to host" after server reboot
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AWI unavailable, ucybsmcl throws "No route to host" after server reboot

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Article ID: 441967

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

Following an unexpected reboot of application or database servers, the Automic Web Interface (AWI) and Service Manager become inaccessible. This occurs even when application processes appear to be running correctly from an OS point of view.

Symptoms

  • AWI is unreachable via load balancer or direct connection (e.g., http://[HOSTNAME]:8080/awi).
  • Service Manager Dialog returns error: invalid message from server.
  • Command line utility ucybsmcl -c GET_PROCESS_LIST returns error: connect: No route to host.
  • Port testing (e.g., tnc -port 8080 [IP]) confirms the port is rejecting connections.

Environment

Version: Any
Components: AWI, Service Manager, WP/CP processes

Cause

An unexpected server reboot can cause the local OS firewall (such as firewalld or Windows Firewall) to default to an Enabled state. This blocks incoming traffic on critical application ports like 8080 (Tomcat/AWI) and 8871 (Service Manager).

Resolution

Involve an OS or network admin who can verify the status of the local firewall on the application server and ensure it is disabled or configured to allow traffic on Automic-specific ports.

  1. Check firewall status (e.g., systemctl status firewalld).
  2. Disable the firewall or add exceptions for ports 8080 and 8871.
  3. Test connectivity using: Review this command before running it.
    bash
    ucybsmcl -c GET_PROCESS_LIST -h [HOSTNAME]:[PORT] -n [SMGR PHRASE]
  4. If connectivity issues persist, see Contact Support. Scroll to the bottom of the page and click on your respective region.

Additional Information

More information on the ucybsmcl application and command syntax can be found here: ServiceManager - Command Line Program (CLI)