SSH connection failed to server <VCFA_FQDN> [VCFMS-PRECHECK-IMPORT-SSH-004]"
Product: VCF 9.1
Component: VCF Operations 9.1, VCF Automation 9.0.x
As part of the precheck workflow a pod-hosted script 'component-action-import-connectivity-xxxx-execute-script-xxxxxxxxx' is run in the vmsp-platform namespace that tests SSH connectivity to the VCF Automation appliance This script retrieves the vmware-system-user password from the vcf-iam-vcfa-admin secret in the vcf-sddc-lcm namespace.
The password being used as part of the precheck is incorrect or contains unsupported special characters.
Firstly, verify the issue is matches.
vmware-system-user.sudo -ikubectl get pods -n vmsp-platform --sort-by=.metadata.creationTimestamp | grep -iv running | tail -20kubectl logs component-action-import-connectivity-xxxx-execute-script-xxxxxxxxx -n vmsp-platform:
Look for an output similar to this. Note the task-import secret name at the end:2026/05/25 09:31:21 INFO {secret_id} Checking SSH connection2026/05/25 09:31:57 ERROR {secret_id} SSH: Failed to connect to <VCFA-FQDN>2026/05/25 09:31:50 INFO {secret_id} Attempting to update precheckMessages in secret task-import-{secret_id}2026/05/25 09:31:50 INFO {secret_id}Successfully updated precheckMessages in secret task-import-{secret_id}
Once confirmation of the SSH failure is achieved, proceed with the following steps to update the credentials.
vcf-iam-vcfa-admin secretkubectl get secret vcf-iam-vcfa-admin -o yaml -n vcf-sddc-lcm
piVersion: v1data:clientId: xxxxxxxxxxxxxxxxxxxxxxxxxxxxclientSecret: ########################kind: Secretmetadata:annotations:
echo <new_password_here> | base64 -w 0vcf-iam-vcfa-admin secret and replace the hash value for clientSecret with the newly generated hash: kubectl editsecret vcf-iam-vcfa-admin -n vcf-sddc-lcm
vmware-system-user in the VCF Operations UI: Navigate toBuild -> Lifecycle -> VCF Management -> Upgrade