HCX upgrade fails with error: "Failed to upload bundle"
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HCX upgrade fails with error: "Failed to upload bundle"

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Article ID: 441884

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Updated On:

Products

VMware HCX

Issue/Introduction

The upgrade bundle file may fail or timeout using the HCX Appliance Management UI (port 9443) with the below error message.

The upgrade bundle file (e.g. VMware-HCX-Connector-upgrade-bundle-4.11.#.#-########.tar.gz.sha256.sig) is not found in the HCX manager /tmp/upgrade/download directory.

Environment

VMware HCX

Cause

This issue occurs because an intermediary device, such as a proxy or firewall, is preventing the file transfer.

Resolution

Verify no proxy, firewall, or intermediary device is impacting the file upload between the local machine and HCX manager.

Troubleshooting Recommendations:

  • Perform simultaneous packet captures on the HCX manager and local machine and inspect the TCP stream using a packet analyzer tool.

    OR
  • Use the local machine web browser diagnostic tools (e.g Developer Tools) to verify the API POST response (found in Network Console) while attempting file upload. 

Additional Information

Upgrade Bundle Download from 443 UI will Fail in All HCX versions prior to 4.11
Packet capture on ESXi using the pktcap-uw tool