VAMi backup (Manual and scheduled ) intermittently failing - "general system error reported"
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VAMi backup (Manual and scheduled ) intermittently failing - "general system error reported"

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Article ID: 441859

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Backup now or Backup schedule fail with error using domain credentials for SMB shared 
  • /var/log/vmware/applmgmt/BackupScheduled.log will have following entries 
    •  BackupSchedule.log:
      • YYYY-MM-DDTHH:MM:SS [0] [MainProcess:PID-25XXXXX] [Scheduler::ExecScheduleRun:Scheduler.py:137] ERROR: Failed to issue the Schedules.run request. Exception: {messages : [LocalizableMessage(id='com.vmware.applmgmt.backup.plugin.internal_server_err', default_message='General system error reported by backup server.', args=['Plugin error occurred. ErrCode: 5, Args: ()'], params=None, localized=None)], data : None, error_type : None}
        Traceback (most recent call last):
          File "/usr/lib/applmgmt/backup_restore/py/vmware/appliance/backup_restore/Scheduler.py", line 133, in ExecScheduleRun
        status = svc_handle.run(scheduleId, comment='SCHEDULED')
          File "/usr/lib/applmgmt/pyclient/applmgmt_client-1.0-py2.7.egg/com/vmware/appliance/recovery/backup_client.py", line 1197, in run
            return self._invoke('run',
          File "/usr/lib/applmgmt/vapi/lib/vapi_runtime-2.100.0-py2.py3-none-any.whl/vmware/vapi/bindings/stub.py", line 345, in _invoke
            return self._api_interface.native_invoke(ctx, methodname, kwargs)
          File "/usr/lib/applmgmt/vapi/lib/vapi_runtime-2.100.0-py2.py3-none-any.whl/vmware/vapi/bindings/stub.py", line 295, in native_invoke
            raise TypeConverter.convert_to_python(method_result.error,  # pylint: disable=E0702
        com.vmware.vapi.std.errors_client.Error: {messages : [LocalizableMessage(id='com.vmware.applmgmt.backup.plugin.internal_server_err', default_message='General system error reported by backup server.', args=['Plugin error occurred. ErrCode: 5, Args: ()'], params=None, localized=None)], data : None, error_type : None}
  • /var/log/vmware/applmgmt/applmgmt.log will have following entries
    •  Applmgmt.log:
      • YYYY-MM-DDTHH:MM:SS  UTC [1979201]ERROR:plugins.SMBClientStorageIOLib:Command failed with error: NT_STATUS_NO_LOGON_SERVERS
        YYYY-MM-DDTHH:MM:SS  UTC [1979201]ERROR:plugins.SMBClientStorageIOLib:smb cmd failed. RC: 1, Err: , Cmd: ['/usr/bin/smbclient', '//<FQDN/IP>/<username>$/', '-A', '/dev/shm/smbCredentialFilej6y32_1_', '-t', '140', '-c', 'cd XXXXXXX/; ls']
        YYYY-MM-DDTHH:MM:SS  UTC [1979201]ERROR:vmware.appliance.vapi.impl:pint.Error('com.vmware.applmgmt.backup.plugin.internal_server_err', 'General system error reported by backup server.', **{'args': ['Plugin error occurred. ErrCode: 5, Args: ()']})

Environment

vCenter Server 7.x, 8.x

Cause

The error NT_STATUS_NO_LOGON_SERVERS indicates that the vCenter Server is unable to reach an Active Directory Domain Controller (DC) to authenticate the domain service account used for the SMB share. This can occur if the account is attempting to reach a DC in a different site or if there is a network/firewall restriction preventing the authentication request from completing during the backup window.

Resolution

To resolve this issue, perform one of the following options:

Option 1: Use a Local SMB Account (Recommended Workaround)

If domain authentication is unstable, use a local user account created specifically on the SMB storage device for backup purposes.

  1. Create a local user on the NAS/SMB server with full read/write permissions to the backup folder.
  2. In the vCenter VAMI (https://:5480), navigate to Backup > Configure.
  3. Update the backup credentials to use the local account format: <ServerName>\<LocalUserName> or simply <LocalUserName>.
  4. Run a manual backup to verify success.

Option 2: Correct Domain Controller Reachability

If a domain account is required by policy, your Active Directory and Network teams must ensure the vCenter and the SMB credentials can communicate with the appropriate DCs.

  1. Verify that the vCenter can resolve and ping the Domain Controllers for the domain being used.
  2. Ensure firewall ports for SMB (445) and AD authentication (88, 135, 389, 636) are open between the vCenter management network, SMB share and the DC network.
  3. Validate that the service account is not locked out and has the "Log on as a batch job" or equivalent permissions on the destination server.
  4. In the VAMI backup settings, ensure the user is entered in the [email protected] format.