Autoping failed from Autosys server to a particular Agent
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Autoping failed from Autosys server to a particular Agent

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Article ID: 44183

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Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) Workload Automation Agent

Issue/Introduction

Autoping is failing from AE server to an Agent.

autoping -m xxxxxxxx123 

CAUAJM_I_50023 AutoPinging Machine [xxxxxxxx123]
CAUAJM_E_10229 Communication attempt with the CA WAAE Agent has failed! [xxxxxxxx123:7530]
CAUAJM_E_50281 AutoPing from the Scheduler WAS NOT SUCCESSFUL. 

CAUAJM_E_10229 Communication attempt with the CA WAAE Agent has failed! [xxxxxxxx123:7530]
CAUAJM_E_50283 AutoPing from the Application Server WAS NOT SUCCESSFUL. 

CAUAJM_E_50026 ERROR: AutoPing WAS NOT SUCCESSFUL. 

Environment

Component: Workload Automation Autosys, Workload Automation Agent

OS: Any

Cause

The issue is with network. The agent only waits for 10 secs between a message being sent and an acknowledgement (ACK) being received. If this time is exceeded, the connection is aborted.

Agent logs may show error like these:

Controller Plugin.Transmitter pool thread <Slow:1>.CybTargetHandlerChannel.a[:1252] - cybermation.library.communications.CybConversationException: connect timed out
at cybermation.library.communications.CybConversation.<init>(CybConversation.java:278)

Resolution

The network administrator should check to see if there is an issue between agent machine and AutoSys.

Additional Information

There is a configuration named “communication.timeout” in the agentparm.txt. It is set by default to 10000 (10 seconds). This may be increased for slower networks.  However, time above 10 seconds are rarely needed.