When upgrading, the import step was not able to complete though it showed completed in the Fleet Manager UI as it failed, timed out, and deployed a fresh virtual appliance.
VCF Automation 9.x
This issue occurs when the Web certificate contains extra certificates in the chain such as a root or leaf certificate. When the migration tries to pass a full or partial certificate chain into Fleet Manager, the Fleet Manager will reject the certificate as it's unsupported in versions before 9.2 (unreleased at the time this KB was created)
Workaround used - before proceeding with the upgrade, in import the leaf certificate directly and remove it from the configured web certificate.