FDM "Table does not exist" error when selecting XML Data option

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Article ID: 4417

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

FDM error "Table does not exist" when selecting XML Data option.

Cause

A default schema is defined to make the reference. Once the connection is established, the list of the tables is displayed and selectable. When the table is added to the Masked Table section, the list of columns is displayed and selectable.

The issue comes when selecting the XPATH option. FDM tries to query the database to obtain the XPATHS information and instead an error is returned stating the table does not exist.

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After several tests, we found out that the issue is related to the queries used internally that are not qualifying the tables. the query is not identifying what schema should be used to run the query and instead is running it over the user group of tables.

Environment

Oracle with TDM 3.8 and FDM

Resolution

The issue is fixed which required changes only in the UI. This fix will be available in TDM 4.0.  If this is needed now and you are running TDM version 3.8 and your Fast Data Masker version is less than 4.6.200.19, please contact Support for a current patch version.

Additional Information

You can download the latest version of TDM by following the directions in this document: https://support.ca.com/us/knowledge-base-articles.TEC1903942.html.   

To contact support, go to https://www.ca.com/us/services-support/ca-support/contact-support.html.    

Attachments

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