Unable to download binaries in VCF OPS 9.1 due to metadata sync timestamp delay
search cancel

Unable to download binaries in VCF OPS 9.1 due to metadata sync timestamp delay

book

Article ID: 441620

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

After you upgrade to VMware Cloud Foundation (VCF) 9.1, selecting a product's binary for download in VCF Ops does not start the download immediately.

The download is scheduled for the current time (UTC), but the metadata download timestamp appears a few hours behind. Additionally, navigating to the VCF Management > Tasks screen also shows tasks running a few hours behind the current time.

Environment

VCF Operations 9.1

Cause

The browser timezone does not match the timezone of the SDDC Manager and VCF Ops appliances. For downloads to begin immediately, the SDDC and Ops timezones must match your browser timezone. If there is a timezone mismatch, the user interface schedules the download for the current SDDC time instead of starting it immediately.

Resolution

To resolve this issue, ensure your browser timezone matches the appliance timezones:

  1. Verify the timezone your browser is currently using by entering the following command into the browser's developer console: console.log(Intl.DateTimeFormat().resolvedOptions().timeZone)
  2. Run the timedatectl command on the SDDC Manager (SDDC-M) and VCF Ops appliances to confirm their configured timezones.
  3. If the timezones do not match, update the browser timezone on the jump server to match the timezone configured on the SDDC and Ops appliances.