重複する ハードウェア ID (HWID) が自動で修復されない
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重複する ハードウェア ID (HWID) が自動で修復されない

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Article ID: 441544

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Products

Endpoint Protection

Issue/Introduction

HWID の修復機能 は有効 ( scm.duplicatedhwkey.fix.enabled=true ) になっているが、時間が経過しても重複が解消されない。

Environment

Symantec Endpoint Protection (SEP) Linux エージェント

Cause

自動修復機能は過剰修復(重複していない端末のIDを誤って変更すること)を防ぐため、特定の条件でのみ動作するように設計されています。 そのため、以下のような条件下においては時間が経過しても重複が自動解消されない場合があります。

  • 同じ HWID を持つ重複クライアントが 2台(ペア) しか存在していない(3台以上存在していない)。
  • ペアのクライアントマシンは再起動なく連続稼働しており、常に 交互に SEPM に接続している。

Resolution

ブロードコムはこの問題を認識しており、解決策が利用可能になったときにこのドキュメントを更新します。

  • 回避策 
    HWID が重複しているマシン上で手動で ID を修復します。
    1. 以下のコマンドを実行して SEP の cafagent デーモンを停止します。
      systemctl stop cafagent
    2. /etc/caf/CAFConfig.ini ファイルのバックアップを取得後、テキストエディタで開きます。
    3. source_id= 行の右側に記載された GUID 値を、ランダムな値に変更して保存します。
      ※フォーマット(大文字、ハイフンなし32桁)を合わせるため、以下のコマンドで生成した値を使用してください。
      uuidgen | tr -d '-' | tr '[:lower:]' '[:upper:]'
    4. 以下のコマンドを実行して SEP の cafagent デーモンを開始します。
      systemctl start cafagent