VCF 9.1 License Server console displays a black screen during boot due to Docker network conflict
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VCF 9.1 License Server console displays a black screen during boot due to Docker network conflict

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Article ID: 441526

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Updated On:

Products

VCF Operations VMware Cloud Foundation VMware vSphere Foundation

Issue/Introduction

  • After deploying the VCF 9.1 License Server and booting it, only a black screen is deployed on the console.
  • The license server appliance is deployed in a network using the IP address range of 172.16.0.0/12 (any IP address from 172.16.0.1 to 172.31.255.254) or is deployed with a gateway that has a routable path of 172.17.0.0/16.

Environment

  • VMware Cloud Foundation 9.1
  • VMware vSphere Foundation 9.1

Cause

The license server appliance’s use of an internal Docker bridge network is not able to function when detecting a conflict with the 172.17.0.0/16 routable path from the gateway.

Resolution

This is a known issue with VVF / VCF 9.1, targeted to be fixed in a future release.

Workaround

  1. Use an IP address not in the 172.16.0.0/12 range for License Server.
    1. Note: This may not resolve the issue if the gateway is still advertising a routable path of 172.17.0.0/16.
    2. To change the IP address of the license server, from the vSphere Client, while the license server VM is powered off, select the license server VM > Configure > vApp Options. After a change is made - power on the license server VM.

  2. If changing the IP address does not resolve the issue, use an alternative gateway that does not use the routable path of 172.17.0.0/16.
    1. Note: If VCF Operations is also using an IP address in the 172.17.0.0/16 range, a static route to the gateway needs to be added between the license server IP address and VCF Operations IP address.