Browser times out before report finishes in Security Analytics
search cancel

Browser times out before report finishes in Security Analytics

book

Article ID: 441338

calendar_today

Updated On:

Products

Security Analytics

Issue/Introduction

In Security Analytics there is a web timeout setting.  If there is no activity in the browser, it will automatically log users off after X number of minutes (defined in Settings > Web Interface > Inactivity Timeout).  The default setting is 5 minutes but can be increased to a maximum of 1 week.  If running a report that takes longer than the web timeout, the browser may time out before the report completes.  Once logged off, the report will automatically terminate within 5 minutes.

Environment

Security Analytics 8.3.1
All web browsers

Cause

The configured Web Interface Inactivity Timeout is shorter than the time required for the report to generate.

Resolution

There are a few ways to improve chances of not getting logged off prematurely.  

  1. Increase the Inactivity Timeout setting (Settings > Web Interface > Inactivity Timeout).
  2. Alter the filter criteria to reduce the data set, which will allow the report to finish more quickly.
  3. Keep the current tab active by manually refreshing the entire tab.
  4. Use a third party browser extension that automates a browser refresh.

If users get logged out before the report finishes, log back in and rerun the report from scratch.

Additional Information