Unable to register components with VCF Operations during greenfield installation of Operations for Networks
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Unable to register components with VCF Operations during greenfield installation of Operations for Networks

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Article ID: 441312

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Updated On:

Products

VCF Operations

Issue/Introduction

  • Error seen when attempting to deploy VCF Operations for Networks:
    • Unable to register components with VCF Operations. Navigate to 'https://<operations appliance>/vcf-operations/ui/home/administration/control-panel/management-tasks/lcm/tasks' for more details.

  • The /storage/log/vcops/log/component-manager-plugin-<random id>.log has something similar to:
INFO component-manager-plugin 31894 [ops@4413 threadId="51249" threadName="ComponentManagerTaskEngine-5" operationId=""] [com.vmware.vrealize.lcm.util.RestClientV2.getSSLConnection] - Using proxy to connect. proxy host: <proxy hostname>, proxy port: 80
...snip...
ERROR component-manager-plugin 31894 [ops@4413 threadId="51249" threadName="ComponentManagerTaskEngine-5" operationId=""] [com.vmware.vrealize.lcm.plugin.core.vrni.driver.helper.VRNIUtils.getAuthTokenV2] - Exception occurred when making REST call VMware Aria Operations for Networks platform
org.bouncycastle.tls.TlsFatalAlert: certificate_unknown(46)
        at org.bouncycastle.jsse.provider.ProvSSLSocketWrap.checkServerTrusted(ProvSSLSocketWrap.java:132)
        at org.bouncycastle.jsse.provider.ProvTlsClient$1.notifyServerCertificate(ProvTlsClient.java:385)
...snip...
Caused by: java.security.cert.CertificateException: Unable to construct a valid chain
        at org.bouncycastle.jsse.provider.ProvX509TrustManager.validateChain(ProvX509TrustManager.java:321)
      ... 28 more
Caused by: java.security.cert.CertPathBuilderException: Unable to find certificate chain.

Environment

VMware Cloud Foundation 9.1

Cause

The proxy connection is SSL terminating, which is not supported.  See Settings in the Network Settings Category

 

Resolution

Remove the configured proxy

  1. In VCF Operations, Navigate to Operate > Administration > Global Settings > Network Settings
  2. Delete the configured proxy.

Reconfigure the proxy after the task is done to re-enable connection to software depot if needed.